summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-05-13 14:44:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-05-13 14:52:17 +0200
commited1e7920393c9ae5b2ae31fc46bae88136239b13 (patch)
tree8abc76463a54a81191f5d6bcb0df766b335c11f4 /gnu/packages/python-xyz.scm
parent6af7a94446239c63784ea08f245bf35b6a13f6e1 (diff)
gnu: python-sentry-sdk: Disable tests not working with pytest-7.
* gnu/packages/python-xyz.scm (python-sentry-sdk)[arguments]: Update 'check' phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 32 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac3a3f683b..b6527221c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,7 +59,7 @@
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
;;; Copyright © 2019, 2023 Jack Hill <jackhill@jackhill.us>
-;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019-2023, Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
@@ -11805,7 +11805,37 @@ you do not want to store entirely on disk or on memory.")
" and not test_httplib_misuse"
;; Fails with IndexError.
" and not test_session_mode_defaults_to"
- "_request_mode_in_wsgi_handler"))))))))
+ "_request_mode_in_wsgi_handler"
+ ;; Tests below fail with pytest 7
+ " and not test_leaks"
+ " and not test_basic"
+ " and not test_keyboard_interrupt_is_captured"
+ " and not test_transaction_with_error"
+ " and not test_transaction_no_error"
+ " and not test_start_span_to_start_transaction"
+ " and not test_tracestate_computation"
+ " and not test_doesnt_add_new_tracestate_to_transaction_when_none_given"
+ " and not test_adds_tracestate_to_transaction_when_to_traceparent_called"
+ " and not test_adds_tracestate_to_transaction_when_getting_trace_context"
+ " and not test_tracestate_is_immutable_once_set"
+ " and not test_to_traceparent"
+ " and not test_to_tracestate"
+ " and not test_sentrytrace_extraction"
+ " and not test_tracestate_extraction"
+ " and not test_iter_headers"
+ " and not test_tracestate_reinflation"
+ " and not test_continue_from_headers"
+ " and not test_memory_usage"
+ " and not test_transactions_do_not_go_through_before_send"
+ " and not test_start_span_after_finish"
+ " and not test_span_trimming"
+ " and not test_transaction_naming"
+ " and not test_start_transaction"
+ " and not test_finds_transaction_on_scope"
+ " and not test_finds_transaction_when_descendent_span_is_on_scope"
+ " and not test_finds_orphan_span_on_scope"
+ " and not test_finds_non_orphan_span_on_scope"
+ " and not test_circular_references"))))))))
(native-inputs
(list python-django
python-executing