summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-07 14:11:55 +0100
committerMarius Bakke <marius@gnu.org>2023-01-07 21:04:26 +0100
commitedbacab9953144a3aa204f9f0eee1584ef321a8f (patch)
tree375b90e501ed9094821796355bf57286052e02a9 /gnu/packages/python-xyz.scm
parenta47c475678c3647be918ebc97cced1e8a2306993 (diff)
gnu: Use old setuptools in packages that relies on use_2to3 conversion.
This fixes a regression since 520cdf80581669646ff61e9f18f3b27045556e76 where the use_2to3 functionality was removed from setuptools. * gnu/packages/graph.scm (python-louvain)[native-inputs]: Change from PYTHON-SETUPTOOLS to PYTHON-SETUPTOOLS-57. * gnu/packages/python-check.scm (python-parameterizedtestcase)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-anyjson)[native-inputs]: Add PYTHON-SETUPTOOLS-57. * gnu/packages/bioinformatics.scm (python-pyvcf)[native-inputs]: Change from PYTHON-SETUPTOOLS-FOR-TENSORFLOW to PYTHON-SETUPTOOLS-57.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0b54443af..df2c7ce52d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15847,8 +15847,8 @@ fast xml and html manipulation.")
;; whatever) so this transformation needs to be done before the tests
;; can be run. Maybe we could add a build step to transform beforehand
;; but it could be annoying/difficult.
- ;; We can enable tests for the Python 2 version, though, and do below.
#:tests? #f))
+ (native-inputs (list python-setuptools-57)) ;for use_2to3 support
(home-page "https://bitbucket.org/runeh/anyjson/")
(synopsis
"Wraps best available JSON implementation in a common interface")