summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 15:53:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit262df6c6071bbed95635a17df3cda44360992ab1 (patch)
tree09f15ddb2532f0b84ea1b6ea242bc4cd83edd55b /gnu/packages/python-xyz.scm
parent78d5fb172079f2fb5f9505f12f516e249e2ca7fe (diff)
gnu: python-dask: Disable some tests.
* gnu/packages/python-xyz.scm (python-dask)[arguments]: Disable ORC tests and those that fail due to differences in job id. Change-Id: I272a77c8291b121b57b02750916f520b52185bbe
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e2b64f984c..4128a5e0d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28060,6 +28060,10 @@ decisions with any given backend.")
;; These all fail with different hashes. Doesn't seem
;; problematic.
"--ignore-glob=**/test_tokenize.py"
+ ;; ORC tests crash Python with a failure to find the global
+ ;; localtime file. See also
+ ;; https://github.com/apache/arrow/issues/40633.
+ "--ignore-glob=**/test_orc.py"
"-k" (string-append
;; This one cannot be interrupted.
"not test_interrupt"
@@ -28067,6 +28071,10 @@ decisions with any given backend.")
;; before assignment". Maybe enable this in later
;; versions (or when pandas has been upgraded.
" and not test_dt_accessor"
+ ;; This fails when dask-expr is among the inputs.
+ " and not test_groupby_internal_repr"
+ ;; This fails with different job ids.
+ " and not test_to_delayed_optimize_graph"
;; This one expects a deprecation warning that never
;; comes.
" and not test_RandomState_only_funcs")