summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-08 22:30:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-08 22:30:41 +0100
commitdc03e6ce50ba9d88b34685db886a3e994f99fc33 (patch)
tree35e9b29f7d1bca5aff8a98b438434b0b7cf0ec44 /gnu/packages/python-xyz.scm
parent09c4818beb3d82d77155c7feaf885fedb23145f3 (diff)
gnu: python-click-default-group: Enable tests.
* gnu/packages/python-xyz.scm (python-click-default-group) [source]: Swap to git checkout containing tests. Change-Id: I51d039ce03d4d772ed6246233e5cc830b5548c3a
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 745e8cb9db..602bc3ab16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18106,14 +18106,16 @@ applications.")
(package
(name "python-click-default-group")
(version "1.2.4")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "click_default_group" version))
- (sha256
- (base32
- "07i5w47lbihcb3cvs08vynz725z9skvhhzrarnk6qi8dxjckqgzb"))))
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/click-contrib/click-default-group")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06h12qwg0lhvxlgfm9768afibwp8j6r3r440v630a30bv0nkhngm"))))
(build-system pyproject-build-system)
- (arguments (list #:tests? #false)) ;there are none
(propagated-inputs
(list python-click))
(native-inputs