summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorAndrew Jose <arnav.jose@gmail.com>2024-04-04 22:46:18 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-07 19:40:00 +0100
commit1977fa35c553f4ba9427876f065f5816f7b70b5b (patch)
tree0acd811b61a669223a3e4484e633d29ff40fb7b2 /gnu/packages/python-xyz.scm
parent1acd3cdc9e18ae1b2994263d738c309166df919a (diff)
gnu: Add python-shshsh.
* gnu/packages/python-xyz.scm (python-shshsh): New variable. Reviewed-by: Steve George <steve@futurile.net> Signed-off-by: Christopher Baines <mail@cbaines.net> Change-Id: Iadd75c769a4391195b32789590f94fd8afbe21b6
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 190284f4d9..92566abfed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20758,6 +20758,35 @@ implementation has been adapted, improved, and fixed from Molten.")
running in.")
(license license:isc)))
+(define-public python-shshsh
+ (package
+ (name "python-shshsh")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/zqqqqz2000/shshsh")
+ (commit
+ "fd21c8696aebaae04507760c16cb45979291fef5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wzqyj1a6jj6cyv5ymzy834qm2lyq80yy1kfz0q0zayq9gm1cj7f"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-poetry-core
+ python-pytest
+ python-tox))
+ (home-page "https://github.com/zqqqqz2000/shshsh")
+ (synopsis "Write Shell commands simply and safely within Python")
+ (description "This package provides a way to write Shell commands from
+within Python. Python functions can be chained together to process input
+Bash control characters are escapted so that parameters can be passed
+without worrying about command injection.")
+ (license license:expat)))
+
(define-public python-memcached
(package
(name "python-memcached")