summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2024-03-17 17:32:31 +0100
committerLudovic Courtès <ludo@gnu.org>2024-03-19 17:19:01 +0100
commit74533133d3cae3c3f97b3e433920877159522d38 (patch)
tree7fccec0b53784820d4f6d229f74e965981efee7e /gnu/packages/python-xyz.scm
parentd082573db1b86d922965dc746627bf0f0cc18af4 (diff)
gnu: Add python-pypugjs.
* gnu/packages/python-xyz.scm (python-pypugjs): New variable. Change-Id: I050ab42d0149fcffddcf6b12dd9c1ddea23f84c9 Signed-off-by: Tanguy Le Carrour <tanguy@bioneland.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f29bb4e1bb..8209e21828 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6057,6 +6057,54 @@ adds a 'now' tag providing a convenient access to the arrow.now() API from
templates. A format string can be provided to control the output.")
(license license:expat)))
+(define-public python-pypugjs
+ (package
+ (name "python-pypugjs")
+ (version "5.9.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kakulukia/pypugjs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zj7a560h973cl7brfw1nmyhgm8rp8j80wnih0shvhmw4ql23lpa"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Our pyramid is outdated and pyramid-mako is not packaged.
+ (add-after 'unpack 'disable-pyramid
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("'pyramid")
+ "#'pyramid"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-v"
+ "pypugjs/testsuite/")))))))
+ (native-inputs (list python-coverage
+ python-django
+ python-jinja2
+ python-flake8
+ python-flask
+ python-mako
+ python-nose
+ python-poetry-core
+ python-pytest
+ python-tornado-6
+ python-wheel))
+ (propagated-inputs (list python-charset-normalizer python-six))
+ (home-page "https://github.com/kakulukia/pypugjs")
+ (synopsis "Convert Pug source files into different template languages")
+ (description
+ "PyPugJS is a high-performance port of PugJS for Python, that converts
+any @file{.pug} source into different template languages: Django, Jinja2,
+Mako, and Tornado.")
+ (license license:expat))) ;; MIT
+
(define-public python-pysdl2
(package
(name "python-pysdl2")