summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:48:42 +0200
commita5db49cae00316c08e3f0bb3d9eb2d42d856e544 (patch)
tree4b17e66ed78fb609bcf0cf76fda7f721c8f3f659 /gnu/packages/python-xyz.scm
parente51daf78e284d9cc1bdb7db5385ac02fea203084 (diff)
gnu: python-jaraco-context: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm: (python-jaraco-context)[build-system]: Move to pyproject-build-system. (python-jaraco)[arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: Ifc9b8fc4a9a6c1c2f37fd014eeee1205cd2eb2c4 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4e09aa59b..d1fce8b505 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11820,7 +11820,7 @@ WeightedLookup: A specialized RangeMap for selecting an item by weights.
(uri (pypi-uri "jaraco.context" version))
(sha256
(base32 "0hbjm1rpxf4pzmbdp9rh3ali4zqnlcr8m97bhh1nizxvzcpxim7h"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments (list #:tests? #f))
(native-inputs (list python-setuptools-scm))
(home-page "https://github.com/jaraco/jaraco.context")
@@ -11837,14 +11837,9 @@ procedures.")
(package-arguments python-jaraco-context-bootstrap)
((#:tests? _ #f)
(not (%current-target-system)))
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the Internet.
- (invoke "pytest" "-vv" "-k" "not project"))))))))
+ ;; Do not test the myproject.toml build as it pulls dependencies.
+ ((#:test-flags test-flags '())
+ '(list "-k" "not project"))))
(native-inputs
(modify-inputs
(package-native-inputs python-jaraco-context-bootstrap)