summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:48:35 +0200
commite51daf78e284d9cc1bdb7db5385ac02fea203084 (patch)
tree2a5c80309885293a570b3a5426d2881ba3f5b22a /gnu/packages/python-xyz.scm
parent8cea52c2ad064f5c3d7af624201ed257f012f97f (diff)
gnu: python-jaraco-classes: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-jaraco-classes): [build-system]: Move to pyproject-build-system. [arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: I8fbe633db7533f933a342b47a4a2191ccf13a8c5 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 162e795511..e4e09aa59b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11724,17 +11724,10 @@ finding unresolved symbols in Python code and their corresponding imports.")
(uri (pypi-uri "jaraco.classes" version))
(sha256
(base32 "0d6g7qvfv1jlzbzh6asprqdblqd59grvlvr3nwbdqdqrmwlbfm7d"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the Internet.
- (invoke "pytest" "-vv" "-k" "not project")))))))
+ (list ; Do not test the myproject.toml build as it pulls dependencies.
+ #:test-flags '(list "-k" "not project")))
(native-inputs
(list python-pytest
python-pytest-black