summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-28 12:19:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:15 +0200
commit3742c7f6dc0e9e7e2bf9375f063f1439361a7137 (patch)
tree2bfb414ba742d87938de693cac30a3e573c67e03 /gnu/packages/python-xyz.scm
parent9779d089827ed4ba76037187cfd956f8f313b3f5 (diff)
gnu: pythonbitstring: Run tests.
* gnu/packages/python-xyx.scm (python-bitstring)[arguments]: Replace check phase. [native-inputs]: Add python-pytesst.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4918f4fafc..43d767b1f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23324,6 +23324,18 @@ Qt applications.")
(base32
"0jl6192dwrlm5ybkbh7ywmyaymrc3cmz9y07nm7qdli9n9rfpwzx"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (with-directory-excursion "test"
+ (invoke "pytest")))
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/scott-griffiths/bitstring")
(synopsis
"Simple construction, analysis and modification of binary data")