summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-10-21 13:14:21 +0000
committerChristopher Baines <mail@cbaines.net>2022-10-22 10:24:25 +0100
commitadd66292debb3048a8b5b7cfbfb5039115b4c4f1 (patch)
treeb718486866e57d4d7e60971425790b00cafc64a5 /gnu/packages/python-xyz.scm
parent95ffc456462f440a006ca446f29f43524179a6b8 (diff)
gnu: python-yq: Update to 3.1.0.
* gnu/packages/python-xyz.scm (python-yq): Update to 3.1.0. [inputs]: Add python-toml. [native-inputs]: Add python-setuptools-scm. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 706de291c9..e58371eb60 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21580,14 +21580,14 @@ style guide, even if the original code didn't violate the style guide.")
(define-public python-yq
(package
(name "python-yq")
- (version "2.11.1")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "yq" version))
(sha256
(base32
- "1q4rky0a6n4izmq7slb91a54g8swry1xrbfqxwc8lkd3hhvlxxkl"))))
+ "1wklgs3d9si475nffw9agq5kgk8bdicbsmlj4sx4kiw64ji4ma1h"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -21602,9 +21602,9 @@ style guide, even if the original code didn't violate the style guide.")
"/bin/jq")))
#t)))))
(inputs
- (list python-argcomplete python-pyyaml python-xmltodict jq))
+ (list python-argcomplete python-pyyaml python-xmltodict python-toml jq))
(native-inputs
- (list python-coverage python-flake8 python-wheel))
+ (list python-coverage python-flake8 python-setuptools-scm python-wheel))
(home-page "https://github.com/kislyuk/yq")
(synopsis "Command-line YAML/XML processor")
(description