summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-06-16 17:24:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-06-16 23:21:40 +0300
commitf1adcfd37a6f8103917e8a34400a33bf763e151c (patch)
tree8879780d585de34a7964c1459ea1f07382338d30 /gnu/packages/python-xyz.scm
parent8d5c55b2e8c56429f7a6713080c2e7bc4dafe983 (diff)
gnu: poetry: Update to 1.0.9.
* gnu/packages/python-xyz.scm (poetry): Update to 1.0.9. [arguments] Adjust required versions of pyrsistent. Remove required version of importlib-metadata. [propagated-inputs] Add python-msgpack-transitional. Remove python-importlib-metadata. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 422e014019..e95dec21c2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11884,7 +11884,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(define-public poetry
(package
(name "poetry")
- (version "1.0.5")
+ (version "1.0.9")
;; Poetry can only be built from source with Poetry.
(source
(origin
@@ -11892,7 +11892,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(uri (pypi-uri "poetry" version))
(sha256
(base32
- "02h387k0xssvv78yy82pcpknpq4w5ym2in1zl8cg9r5wljl5w6cf"))))
+ "1avp0db1a4hf6lz3wrzhpdvj4rpmzr4in3myrd3lp5j66nc5ck0a"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ;; Pypi does not have tests.
@@ -11903,8 +11903,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(substitute* "setup.py"
;; poetry won't update version as 21.0.0 relies on python > 3.6
(("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")
- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.16.0")
- (("importlib-metadata>=1.1.3,<1.2.0") "importlib-metadata>=1.1.3,<1.5.0"))
+ (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0"))
#t)))))
(propagated-inputs
`(("python-cachecontrol" ,python-cachecontrol)
@@ -11912,9 +11911,9 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
("python-cleo" ,python-cleo)
("python-clikit" ,python-clikit)
("python-html5lib" ,python-html5lib)
- ("python-importlib-metadata" ,python-importlib-metadata) ;; python < 3.8
("python-jsonschema" ,python-jsonschema)
("python-keyring" ,python-keyring)
+ ("python-msgpack-transitional" ,python-msgpack-transitional)
("python-pexpect" ,python-pexpect)
("python-pkginfo" ,python-pkginfo)
("python-pyparsing" ,python-pyparsing)