summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
commit34f849a945d25daa76d93839dcf8768c8b45b636 (patch)
tree33cde8cf068593f29366ba3702aabdb75b5fa126 /gnu/packages/python-xyz.scm
parent0897ad7fac04fc9d814e83eed46e88c7bf9740bc (diff)
parentc09f598d94af81f326fe1d4cf2ab344d4e720679 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f4a2334d9..9095984811 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4088,8 +4088,7 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(assoc-ref inputs "jquery-ui")
"-d" dir))
#t))
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests.py" "-v"
@@ -4147,6 +4146,7 @@ toolkits.")
(assoc-ref inputs "jquery-ui")
"-d" dir))
#t))
+ (delete 'fix-and-disable-failing-tests)
(delete 'check))))) ; These tests weren't run the the past.
;; Make sure to use special packages for Python 2 instead
;; of those automatically rewritten by package-with-python2.