summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 11:37:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 11:43:19 +0100
commit8b85aea49bc63355bffdf79a97effec6a0ba2f91 (patch)
treebc6dd09e765a645e37cd2a82193cabc90cdeae88 /gnu/packages/python-xyz.scm
parent714a8faa0469b4c79a0694f1451e7b1a6214d12f (diff)
gnu: Add python-uncertainties.
* gnu/packages/python-xyz.scm (python-uncertainties): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3535649c0d..b308948728 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11558,6 +11558,34 @@ document.")
manipulation library.")
(license license:expat)))
+(define-public python-uncertainties
+ (package
+ (name "python-uncertainties")
+ (version "3.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "uncertainties" version))
+ (sha256
+ (base32
+ "00z9xl40czmqk0vmxjvmjvwb41r893l4dad7nj1nh6blw3kw28li"))))
+ (build-system python-build-system)
+ ;; While there are test files, there is no "tests" directory, so the tests
+ ;; fail.
+ (arguments '(#:tests? #false))
+ (propagated-inputs
+ `(("python-future" ,python-future)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-numpy" ,python-numpy)))
+ (home-page "https://uncertainties-python-package.readthedocs.io/")
+ (synopsis "Calculations with uncertainties")
+ (description
+ "The uncertainties package transparently handles calculations with
+numbers with uncertainties. It can also yield the derivatives of any
+expression.")
+ (license license:bsd-3)))
+
(define-public python-boto
(package
(name "python-boto")