summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-14 14:08:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-15 09:29:33 +0200
commitbab0c30be31944a3f2ea3fe99269859db192ffea (patch)
tree46b599a5acb0c0362ad12f697eb06f0e5308cddf /gnu/packages/python-xyz.scm
parent78b043bb908813c01b2c6dbde16b310971ca85f5 (diff)
gnu: Add python-structlog.
* gnu/packages/python-xyz.scm (python-structlog): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cc21caa721..d0548c2ac2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10785,6 +10785,41 @@ applications.")
(home-page "https://github.com/click-contrib/click-log")
(license license:expat)))
+(define-public python-structlog
+ (package
+ (name "python-structlog")
+ (version "20.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "structlog" version))
+ (sha256
+ (base32
+ "0x1i21vn3xjfa3j9ijbblia5z0jlzc9aqvpqc26sy16i8yjxyydg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest"))
+ #t)))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-freezegun" ,python-freezegun)
+ ("python-pretend" ,python-pretend)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)
+ ("python-simplejson" ,python-simplejson)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://www.structlog.org/")
+ (synopsis "Structured Logging for Python")
+ (description "@code{structlog} changes logging in Python by adding structure
+to your log entries.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public python-apipkg
(package
(name "python-apipkg")