summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:33:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:33:58 +0300
commitbb9061c9e0ec39397eaf9a7cff481633608268dd (patch)
tree1d1b4500b47d1be3d58a5feb92139fc19cb3730d /gnu/packages/python-xyz.scm
parent0f1e0882804601e181951b45921b618a7709cb85 (diff)
gnu: Add python-flufl-testing.
* gnu/packages/python-xyz.scm (python-flufl-testing): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 612098ece0..beaed485bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20792,3 +20792,24 @@ timeouts for POSIX systems. It is similar to the @code{O_EXCL} option of the
and have a maximum lifetime built-in.")
(license (list license:asl2.0
license:lgpl3)))) ; only for setup_helpers.py
+
+(define-public python-flufl-testing
+ (package
+ (name "python-flufl-testing")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flufl.testing" version))
+ (sha256
+ (base32
+ "1nkm95mhcfhl4x5jgs6y97ikszaxsfh07nyawsih6cxxm6l62641"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose2" ,python-nose2)))
+ (home-page "https://gitlab.com/warsaw/flufl.testing")
+ (synopsis "Collection of test tool plugins")
+ (description
+ "This package contains a small collection of test tool plugins for
+@code{nose2} and @code{flake8}.")
+ (license license:asl2.0)))