summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 22:03:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:33 +0100
commitc5d399090e2a3f5a742fcdf4e514f0f8ab6fe491 (patch)
tree8e16385dcca13f9de1ffb0f825e7e849a5472699 /gnu/packages/python-xyz.scm
parent17263ef5e84029ddaadef3ab40fcba7cbc9d6c43 (diff)
gnu: python-pytest: Update to 5.3.2.
* gnu/packages/check.scm (python-pytest): Update to 5.3.2. [propagated-inputs]: Add PYTHON-WCWIDTH and PYTHON-PACKAGING-BOOTSTRAP. [native-inputs]: Add PYTHON-XMLSCHEMA. [arguments]: Support overriding check phase with #:tests?. (python2-pytest): Stay on version 4.4.2. (python2-pytest-bootstrap): Inherit from PYTHON2-PYTEST instead of PYTHON-PYTEST-BOOTSTRAP. * gnu/packages/python-xyz.scm (python-packaging-bootstrap): New public variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f37da99d5..618049e4bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13121,6 +13121,17 @@ information.")
;; licenses.
(license (list license:asl2.0 license:bsd-2))))
+;; A variant with minimal dependencies, for bootstrapping Pytest.
+(define-public python-packaging-bootstrap
+ (hidden-package
+ (package/inherit
+ python-packaging
+ (name "python-packaging-bootstrap")
+ (native-inputs '())
+ (propagated-inputs
+ `(("python-pyparsing" ,python-pyparsing)))
+ (arguments '(#:tests? #f)))))
+
(define-public python2-packaging
(package-with-python2 python-packaging))