summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-21 22:24:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-21 22:24:27 +0200
commitc721e00ef19b3eb86c8eca78102cbe7d31ea27af (patch)
treedc21dea410e20c909d8116c17e0d5eab166ae341 /gnu/packages/python-xyz.scm
parent9a757283186766aabd9e179ad8516e724ec16fa1 (diff)
gnu: python-pygithub: Update to 1.54.1.
* gnu/packages/python-xyz.scm (python-pygithub): Update to 1.54.1. [arguments]: Remove 'disable-failing-tests, 'prepare-for-tests phases. Add custom 'check phase. [propagated-inputs]: Add python-cryptography. [native-inputs]: Add python-httpretty, python-pytest.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 14 insertions, 20 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88c472d50f..bbe52ff5eb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3815,7 +3815,7 @@ to deprecate classes, functions or methods.")
(define-public python-pygithub
(package
(name "python-pygithub")
- (version "1.43.8")
+ (version "1.54.1")
(source
;; We fetch from the Git repo because there are no tests in the PyPI
;; archive.
@@ -3826,30 +3826,24 @@ to deprecate classes, functions or methods.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1625v558xga5mwhl9jqmibywy5qafmg1vqrirqz6zfq1la1d22mw"))))
+ (base32 "1nl74bp5ikdnrc8xq0qr25ryl1mvarf0xi43k8w5jzlrllhq0nkq"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- ;; Some tests rely on the network.
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/Issue142.py"
- (("testDecodeJson") "disabled_testDecodeJson"))
- #t))
- (add-before 'check 'prepare-for-tests
- (lambda _
- (for-each (lambda (f)
- (chmod f #o666))
- (find-files "./tests"))
- (system* "python" "-m" "lib2to3" "-w" "-n" "tests")
- (setenv "PYTHONPATH"
- (string-append "./tests:" (getenv "PYTHONPATH")))
- #t)))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))
+ #t)))))
(propagated-inputs
- `(("python-deprecated" ,python-deprecated)
+ `(("python-cryptography" ,python-cryptography)
+ ("python-deprecated" ,python-deprecated)
("python-pyjwt" ,python-pyjwt)
("python-requests" ,python-requests)))
- (native-inputs `(("python-httpretty" ,python-httpretty)))
+ (native-inputs
+ `(("python-httpretty" ,python-httpretty)
+ ("python-pytest" ,python-pytest)))
(home-page "https://pygithub.readthedocs.io/en/latest/")
(synopsis "Python library for the GitHub API")
(description "This library allows managing GitHub resources such as