summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-06 00:00:24 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-06 00:14:32 +0100
commitdb5a70c81dba2545d6114d5c41bfc7192ac27cd5 (patch)
tree13002b02c042825ce5762410a03403ada95d7698 /gnu/packages/python-xyz.scm
parentae2231559c8d33c222aa9a3b8cdb6aa5d49c8931 (diff)
gnu: Add python-readability.
* gnu/packages/python-xyz.scm (python-readability): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fbc9ad688d..4e8a28ee6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24016,3 +24016,27 @@ and frame grabber interface.")
"This package provides a command-line interface (CLI) to the Jinja2
template engine.")
(license license:bsd-3)))
+
+(define-public python-readability
+ (package
+ (name "python-readability")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "readability" version))
+ (sha256
+ (base32
+ "1b8gq3g2zwvx0aivvdg56cc0bn7xw6f2v6psmxdx9aiipkw0s0zr"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/andreasvc/readability/")
+ (synopsis
+ "Measure the readability of a given text using surface
+characteristics")
+ (description
+ "This package provides a Python library that is an implementation of
+traditional readability measures based on simple surface
+characteristics. These measures are basically linear regressions based on the
+number of words, syllables, and sentences.")
+ (license license:asl2.0)))