summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-03-14 18:34:42 -0500
committerLeo Famulari <leo@famulari.name>2019-03-14 21:42:09 -0400
commitfe4a4bd23aa55bc6e8f5639db0dbfb358df99861 (patch)
tree0d8d0e03fc83664c611bd9624eb291d8f33d6b99 /gnu/packages/python-xyz.scm
parent138950a88b96a42d09e4d4a490444a0918a2842b (diff)
gnu: python-language-server: Update to 0.25.0.
* gnu/packages/python-xyz.scm (python-language-server): Update to 0.25.0. [propagated-inputs]: Add python-pylint. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab8e543295..706524bbb6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2634,14 +2634,14 @@ Server (PLS).")
(define-public python-language-server
(package
(name "python-language-server")
- (version "0.24.0")
+ (version "0.25.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-language-server" version))
(sha256
(base32
- "05zmv6jr7qbgnkz0lqh5pr7kr4lm12i8ljm2k5h5kz3q9m8d4mm0"))))
+ "1xabnaqd4n72myrc3mxl2y33vr2p7c9c5a87n77p9k327ckvdx01"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pluggy" ,python-pluggy)
@@ -2653,7 +2653,8 @@ Server (PLS).")
("python-pycodestyle" ,python-pycodestyle)
("python-mccabe" ,python-mccabe)
("python-rope" ,python-rope)
- ("python-autopep8" ,python-autopep8)))
+ ("python-autopep8" ,python-autopep8)
+ ("python-pylint" ,python-pylint)))
(home-page "https://github.com/palantir/python-language-server")
(synopsis "Python implementation of the Language Server Protocol")
(description