summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:30:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:30:31 +0000
commit18240ae446e313f1f167d5a1b32004edf3f4d04c (patch)
tree91b678aec621f1f0723752547425939db71bdb84 /gnu/packages/python-xyz.scm
parent4daeae85839ae55f42f93a4a1fd42656733dc75a (diff)
gnu: python-humanize: Update to 4.0.0.
* gnu/packages/python-xyz.scm (python-humanize): Update to 4.0.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-freezegun and python-pytest. Change-Id: I46d06824eb9b43a3540f7b3880ec06f895c290d5
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f3612a0d8..60a1a9a80b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27864,17 +27864,17 @@ the Trio framework}.")
(define-public python-humanize
(package
(name "python-humanize")
- (version "0.5.1")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "humanize" version))
(sha256
(base32
- "06dvhm3k8lf2rayn1gxbd46y0fy1db26m3h9vrq7rb1ib08mfgx4"))))
- (arguments
- '(#:tests? #f)) ; tests not in pypi archive
- (build-system python-build-system)
+ "006vpl19bffy9fn0sssxbfakcvgrx7fhvy6l515fzln7vwpqf7zf"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-freezegun python-pytest))
(home-page "https://github.com/jmoiron/humanize")
(synopsis "Print numerical information in a human-readable form")
(description "This package provides a Python module that displays numbers