summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-25 14:08:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-25 15:13:52 +0100
commit250477d89698309842fb51fd46020ddabfc75a13 (patch)
tree3a1e004dfe6bdfbc4d528962d9a669108b915522 /gnu/packages/python-xyz.scm
parent72a758bcd37319ce2cd3c8944fecb5ca5ef449bf (diff)
gnu: Add python-gh-md-to-html.
* gnu/packages/python-xyz.scm (python-gh-md-to-html): New variable. Change-Id: I8a7f62000eec0636d2c1114c53c852fa136576b1
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bbaf33d1ba..6149807e77 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1888,6 +1888,32 @@ progress bar and a percentage indicator object that let you track the progress
of a loop structure or other iterative computation.")
(license license:bsd-3)))
+(define-public python-gh-md-to-html
+ (package
+ (name "python-gh-md-to-html")
+ (version "1.21.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gh_md_to_html" version))
+ (sha256
+ (base32 "1cnaqnckpcrpc4b8ba18s5ds05w1yfiszcp7ql7pmx0jnrj25qax"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (propagated-inputs
+ (list python-beautifulsoup4
+ python-emoji
+ python-pillow
+ python-requests
+ python-shellescape
+ python-webcolors))
+ (home-page "https://github.com/phseiff/github-flavored-markdown-to-html/")
+ (synopsis "Github-flavored Markdown")
+ (description
+ "This package provides a feature-rich Github-flavored Markdown to HTML
+Python library and command line interface.")
+ (license license:expat)))
+
(define-public python-glymur
(package
(name "python-glymur")