summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 00:00:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:34 +0100
commit32edfc4a8509649c4c20a9c46d21cbe281b9a9d1 (patch)
tree2f11779ce8a1123f2228a22e5d1477a9e291a839 /gnu/packages/python-xyz.scm
parent6fbbffd6efeed580faf9bb1e315a9875f6178276 (diff)
gnu: python-imageio: Update to 2.33.1.
* gnu/packages/python-xyz.scm (python-imageio): Update to 2.33.1. [propagated-inputs]: Remove python-psutil; add python-tifffile. [native-inputs]: Add python-black, python-flake8, python-fsspec, and python-pytest-cov. Change-Id: I5c64d939f5ee94ac9ec8fdbd7b51cd978b7df0fb
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12f649ff15..95e8258a74 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9717,14 +9717,14 @@ from FFMPEG, reliably terminating the process when done.")
(define-public python-imageio
(package
(name "python-imageio")
- (version "2.26.0")
+ (version "2.33.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "imageio" version))
(sha256
(base32
- "0dgddhi5dlpry5j4d3256v09pcziyj3ii47yx0zi68xprm11d7qn"))))
+ "1kn1gj9vc1mkirs39x3nkw2d56paiagi24kkxksrig9pn502swkq"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -9751,9 +9751,10 @@ from FFMPEG, reliably terminating the process when done.")
(delete-file "tests/test_freeimage.py"))))))
(inputs (list freeimage))
(propagated-inputs
- (list python-imageio-ffmpeg python-numpy python-pillow python-psutil))
+ (list python-imageio-ffmpeg python-numpy python-pillow python-tifffile))
(native-inputs
- (list python-pytest))
+ (list python-black python-flake8 python-fsspec python-pytest
+ python-pytest-cov))
(home-page "https://imageio.github.io/")
(synopsis "Library for reading and writing a wide range of image data")
(description