summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-04 16:47:15 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-07 13:50:53 +0100
commit4ad6872979f91633d3287a344c93a4707fa678af (patch)
tree274da47662866b059d40ce166f316828859e3a8f /gnu/packages/python-xyz.scm
parent0a1d503b284bf304663fdbaa9dd465b339ef730d (diff)
gnu: python-shapely: Update to 2.0.2.
* gnu/packages/python-xyz.scm (python-shapely): Update to 2.0.2. [native-inputs]: Remove python-pytest-cov. Change-Id: I4358c16d53c97a0cd38e3689d65ead770b2e997c Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c68b17b0ab..a645c45a4c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2265,13 +2265,13 @@ with Numpy and SciPy.")
(define-public python-shapely
(package
(name "python-shapely")
- (version "2.0.1")
+ (version "2.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "shapely" version))
(sha256
- (base32 "14v88k0y7qhp8n5clip6w96pkdzrfqa2hsjkhpy9gkifwyiv39k6"))))
+ (base32 "1rs90q4ys5cav0hz1dq72wq2mk4aqlqqbfjrnb2zzfkiq42cq4qp"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2282,8 +2282,7 @@ with Numpy and SciPy.")
;; Cython extensions have to be built before running the tests.
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
- (list python-cython python-matplotlib python-pytest
- python-pytest-cov))
+ (list python-cython python-matplotlib python-pytest))
(inputs
(list geos))
(propagated-inputs