summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-15 22:45:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-15 23:06:15 +0100
commit7dfe41aa71a4a4a9d6065a44e9c6271717215b3e (patch)
tree546ff4a49abdaeaaabef9aa885ce8a8c200784f0 /gnu/packages/python-xyz.scm
parentaa51d1d25fbfd711e5f863c0c818f6b05f33c6db (diff)
gnu: Add python-nr-stream.
* gnu/packages/python-xyz.scm (python-nr-stream): New variable. Change-Id: I59489156e4675a64a31b1cb7f62b7c845c005ce8
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d0564e25b..b4cccad062 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1449,6 +1449,25 @@ bindings to the C++ random forest implementation, ranger, using Cython.")
library in pure Python.")
(license license:expat)))
+(define-public python-nr-stream
+ (package
+ (name "python-nr-stream")
+ (version "1.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nr_stream" version))
+ (sha256
+ (base32 "0rag4vbjnalkyfcarx6yipn11ih2hmc3pfldava4c6n6pz31c0pb"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/NiklasRosenstein/python-nr.stream")
+ (synopsis "Stream and Optional classes for Python")
+ (description "This package provides a @code{Stream} and @code{Optional}
+class.")
+ (license license:expat)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")