summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-01-15 23:49:35 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 21:26:05 +0000
commit96895a65b41cc273e53cfb4665400671d83a046c (patch)
tree84b355474bcb527af20cf1f1982719523149f0c8 /gnu/packages/python-xyz.scm
parentc2f5d0f7d8d58aa48b5f83f38e4395b7d22955cd (diff)
gnu: Add python-apscheduler.
* gnu/packages/python-xyz.scm (python-apscheduler): New variable. Change-Id: Ib5964520a8d3c9c4711ba2ee4c5812241dc93423 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dd8a12af5..4aa0271de2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27992,6 +27992,42 @@ format.")
access the system cron automatically and simply using a direct API.")
(license license:lgpl3+)))
+(define-public python-apscheduler
+ (package
+ (name "python-apscheduler")
+ (version "3.10.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "APScheduler" version))
+ (sha256
+ (base32
+ "0jpg9jyx95jafkq0hz6sx7r4l2z5gc599ivb9278kgnr4wdhgpz6"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pytz
+ python-six
+ python-tzlocal))
+ (native-inputs (list python-mock
+ python-twisted
+ python-gevent
+ python-setuptools-scm
+ python-sqlalchemy
+ python-pyside-6
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-pytest-tornado5))
+ (home-page "https://github.com/agronholm/apscheduler")
+ (synopsis "Task scheduling library for Python")
+ (description "Advanced Python Scheduler (APScheduler) is a Python library
+that lets you schedule your Python code to be executed later, either just once
+or periodically.
+
+You can add new jobs or remove old ones on the fly as you please. If you store
+your jobs in a database, they will also survive scheduler restarts and maintain
+their state. When the scheduler is restarted, it will then run all the jobs it
+should have run while it was offline.")
+ (license license:expat)))
+
(define-public python-pylzma
(package
(name "python-pylzma")