summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 13:26:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:48 +0100
commita313875476aaa2c401dde56e77a483f9cda03d49 (patch)
tree8f4f732ba3feb53ca4f206cd92beca7c27c8ae47 /gnu/packages/python-xyz.scm
parent561d429aa4d4cb5c4cc2963631c274f7de474973 (diff)
gnu: Add python-tasklogger.
* gnu/packages/python-xyz.scm (python-tasklogger): New variable. Change-Id: I53319b70b7788090e8873a912d7c56044c0bb5b2
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b23108fbf4..bbaf33d1ba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14992,6 +14992,27 @@ tasks, sockets, files, locks, and queues.")
designed to efficiently cope with extremely large amounts of data.")
(license license:bsd-3)))
+(define-public python-tasklogger
+ (package
+ (name "python-tasklogger")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tasklogger" version))
+ (sha256
+ (base32 "1901mibcp6aiyjy8afnybrxnb0dkbdxlbvjqbr3gginlw7dr18xh"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-deprecated))
+ (native-inputs (list python-coverage python-coveralls python-nose2
+ python-numpy))
+ (home-page "https://github.com/scottgigante/tasklogger")
+ (synopsis "Extension to the core Python logging library")
+ (description "This package provides an extension to the core Python
+logging library for logging the beginning and completion of tasks and
+subtasks.")
+ (license license:gpl2)))
+
(define-public python-sniffio
(package
(name "python-sniffio")