summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-15 22:44:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-15 23:06:15 +0100
commitaa51d1d25fbfd711e5f863c0c818f6b05f33c6db (patch)
treefb3366dbd812638ebf4030b413ba755684330746 /gnu/packages/python-xyz.scm
parent7a2d1287795318d40850949c88679fcbb4f78b4b (diff)
gnu: Add python-nr-date.
* gnu/packages/python-xyz.scm (python-nr-date): New variable. Change-Id: I4251aef073df29ccada70f1398bce38cfb8962ba
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f224ab4eb8..8d0564e25b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1429,6 +1429,26 @@ generator MkDocs.")
bindings to the C++ random forest implementation, ranger, using Cython.")
(license license:gpl3+)))
+(define-public python-nr-date
+ (package
+ (name "python-nr-date")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nr_date" version))
+ (sha256
+ (base32 "1rnjyykjp41mqz6h1vx18jblq97gi5m5x7dgasyaihnd7fhswhq6"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-dataclasses))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/NiklasRosenstein/python-nr.date")
+ (synopsis "Fast, regex-based date parsing library in plain Python")
+ (description "This package provides a fast, regex-based date parsing
+library in pure Python.")
+ (license license:expat)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")