summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-05 14:38:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-05 14:40:19 +0100
commit6c0430f07a7e01ad695d7648f56e8f08307c1fff (patch)
tree7456024464ee08a91e7062ae4823e221dac48dd6 /gnu/packages/python-xyz.scm
parentc8e3e78f8e7209219eb5ab3f3a9fb91c72dc61a0 (diff)
gnu: python2-matplotlib: Remove python-cairocffi.
* gnu/packages/python-xyz.scm (python2-matplotlib)[propagated-inputs]: Remove python-cairocffi, because it cannot be built with Python 2.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e296e3c6e1..a33aa4962f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2020 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
@@ -5216,7 +5216,10 @@ toolkits.")
("python2-subprocess32" ,python2-subprocess32)
("python2-tkinter" ,python-2 "tk")
,@(fold alist-delete (package-propagated-inputs matplotlib)
- '("python-pycairo" "python-pygobject" "python-tkinter")))))))
+ '("python-cairocffi"
+ "python-pycairo"
+ "python-pygobject"
+ "python-tkinter")))))))
(define-public python-matplotlib-documentation
(package