summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-28 17:56:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-28 17:59:59 +0200
commit37d9e96f66084875e8abe3df4c2e13aa9fdf4590 (patch)
treed9615097dc4ea08f156e203732e40fcf4eb556f2 /gnu/packages/python-xyz.scm
parente408677f33d9256bfada64605aa9eb179ee51a20 (diff)
gnu: Add python-zeroc-ice.
* gnu/packages/python-xyz.scm (python-zeroc-ice): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f0005faa2..54b414ab79 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32044,6 +32044,26 @@ functions
markdown-compliant strings.")
(license license:expat)))
+(define-public python-zeroc-ice
+ (package
+ (name "python-zeroc-ice")
+ (version "3.7.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "zeroc-ice" version))
+ (sha256
+ (base32
+ "0bqkrjxp2fbz34x3wxkxji39kxinypzg8q2994sibiay29mpipxb"))))
+ (build-system pyproject-build-system)
+ (inputs (list openssl))
+ (home-page "https://zeroc.com")
+ (synopsis "RPC framework")
+ (description
+ "Ice is a comprehensive RPC framework. Ice helps you network your
+software by taking care of all interactions with low-level network programming
+interfaces.")
+ (license license:gpl2)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar