summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:31:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:45:29 -0400
commit5174820753be045ba4fc7cc93da33f4e0b730bc3 (patch)
treeda362d775be33f41584b615ed918dd944e23480c /gnu/packages/python-xyz.scm
parentcb2e7efa6c17f02c7051bcf6e0d1b8b869ebcce7 (diff)
gnu: python-pre-commit: Move deprecated variable next to replacement.
This fixes a module import dependency cycle, which was introduced in 831baaf81e57ce9d9053ba6f9e0653a2d27298c4 ("gnu: python-pre-commit: Replace with pre-commit."). The rule of thumb to avoid these is that the deprecated package should live next to the replacement package (in the same module). * gnu/packages/python-xyz.scm (python-pre-commit): Move to... * gnu/packages/version-control.scm (python-pre-commit): ... here.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a49c9f194..10df74fc45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24391,9 +24391,6 @@ Features:
@end itemize")
(license license:asl2.0)))
-(define-public python-pre-commit
- (deprecated-package "python-pre-commit" pre-commit))
-
(define-public python-precis-i18n
(package
(name "python-precis-i18n")