summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-03-14 11:03:06 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:26:27 -0400
commit5ef775d6188b29a7423f79bef2c65dd523f5b014 (patch)
tree8c57d8f835302ccfececcce1a2d2549a112b73b8 /gnu/packages/python-xyz.scm
parent966a77b9e4cb2e682e13414846f0bb28b819df08 (diff)
gnu: Add python-treelib.
* gnu/packages/python-xyz.scm (python-treelib): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78ab8af6be..8835d9691d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9453,6 +9453,24 @@ is a distinct layer on top of traitlets, so you can use traitlets in your code
without using the configuration machinery.")
(license license:bsd-3)))
+(define-public python-treelib
+ (package
+ (name "python-treelib")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "treelib" version))
+ (sha256
+ (base32
+ "1247rv9fbb8pw3xbkbz04q3vnvvva3hcw002gp1clp5psargzgqw"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-future))
+ (home-page "https://github.com/caesar0301/treelib")
+ (synopsis "Implementation of a tree structure in Python")
+ (description
+ "This package provides a Python implementation of a tree structure.")
+ (license license:asl2.0)))
+
(define-public python-jupyter-core
(package
(name "python-jupyter-core")