summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-03-18 07:49:23 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-04-02 11:19:21 +0200
commitac30e9766416d0df76cdd4bf8f419a32d870f6fe (patch)
tree5d135b8e95468b5f4c42ddf1a9748813aa132431 /gnu/packages/python-xyz.scm
parentf0c8cb44a4d912263025616bc921c011fcb1f0b4 (diff)
gnu: Add python-imageio-ffmpeg.
* gnu/packages/python-xyz.scm (python-imageio-ffmpeg): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca6c68ec7c..5a845340f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8165,6 +8165,35 @@ converting, and viewing many of the proprietary file formats used to store
experimental data and metadata at the Laboratory for Fluorescence Dynamics.")
(license license:bsd-3)))
+(define-public python-imageio-ffmpeg
+ (package
+ (name "python-imageio-ffmpeg")
+ (version "0.4.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio-ffmpeg" version))
+ (sha256
+ (base32
+ "1a8as5c42s8yl79gc2nhj6vvkwr81p5ibxp5m1zhn1zy22nhbapx"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-ffmpeg
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "imageio_ffmpeg/_utils.py"
+ (("os\\.getenv\\(\"IMAGEIO_FFMPEG_EXE\".*\\)" all)
+ (string-append "(" all " or \""
+ (search-input-file inputs "bin/ffmpeg")
+ "\")"))))))))
+ (inputs (list ffmpeg-4))
+ (build-system python-build-system)
+ (home-page "https://github.com/imageio/imageio-ffmpeg")
+ (synopsis "FFMPEG wrapper for Python")
+ (description "This package provides an FFMPEG wrapper for working with video
+files. It implements generator functions for reading and writing data to and
+from FFMPEG, reliably terminating the process when done.")
+ (license license:bsd-2)))
+
(define-public python-imageio
(package
(name "python-imageio")