summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-11 19:02:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-12 14:18:13 +0200
commitb1c3d7a20d4b2811d2a45709b154ef5b68bd3766 (patch)
treeb31e3b1e3f1a037a0eb20f6efc7867c4c463692e /gnu/packages/python-xyz.scm
parent3ff587f8b092bcef5a54203a651796f4ec473111 (diff)
gnu: python-absl-py: Fix Python version check.
* gnu/packages/python-xyz.scm (python-absl-py)[build-system]: Use pyproject-build-system. [arguments]: Add 'patch-version-check build phase to bypass broken version check.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c11b9a9d65..ae20f48ac6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
@@ -24350,7 +24350,16 @@ RFC 8265 and RFC 8266.")
(sha256
(base32
"1mp9lk0b2qa37b7y6ak4lvf6ifw2ylyy6bkf9ik77md3j4xrwlc7"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-version-check
+ (lambda _
+ ;; Python 3.10 is indeed more recent than Python 3.4.
+ (substitute* "setup.py"
+ ((" or py_version\\[0\\] == '3'.*") ":")))))))
(propagated-inputs
(list python-six))
(home-page "https://github.com/abseil/abseil-py")