summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-04-23 00:10:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-05-11 11:54:41 +0200
commit2528f3c867b1e180136961376ed0136103cb6a47 (patch)
tree60a7f2fd1803492c37444391d4bc003af78e51dd /gnu/packages/python.scm
parent3cdab3d485d334008ea45f4993026a69b70489c2 (diff)
gnu: Add python-idna-ssl.
* gnu/packages/python.scm (python-idna-ssl): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c7851efe5e..ee9d061ef5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6285,6 +6285,26 @@ specification.")
(define-public python2-idna
(package-with-python2 python-idna))
+(define-public python-idna-ssl
+ (package
+ (name "python-idna-ssl")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "idna-ssl" version))
+ (sha256
+ (base32
+ "0ydrc8hpg9mdr5hqq1lqfsfbn6sjq69slwpfrnlrm3k0phqg14qj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;circular dependency with python-aiohttp
+ (home-page "https://github.com/aio-libs/idna-ssl")
+ (synopsis "Patch @code{ssl.match_hostname} for Unicode(idna) domains support")
+ (description "Patch @code{ssl.match_hostname} for Unicode(idna)
+domains support.")
+ (license license:expat)))
+
(define-public python-pretend
(package
(name "python-pretend")