summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-06 11:26:34 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-06 11:30:15 +0100
commit3a735ecf0e501b573a29d273d6b8e2ace5a2c431 (patch)
treea054ab12677c90cb9ec9d8d83931a1767350c8fb /gnu/packages/python.scm
parentc4abbac3495fcb43491625c290cc19141dccd421 (diff)
gnu: python2-notebook: Fix build.
* gnu/packages/python.scm (python2-notebook)[properties]: Add python2-variant. (python2-notebook)[native-packages] add python2-mock. [arguments] Add phase "disable-test-case" for disabling a failing test. immediately
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d51dd4b9e0..d624229640 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6866,10 +6866,28 @@ convert an @code{.ipynb} notebook file into various static formats including:
(description
"The Jupyter HTML notebook is a web-based notebook environment for
interactive computing.")
+ (properties `((python2-variant . ,(delay python2-notebook))))
(license license:bsd-3)))
(define-public python2-notebook
- (package-with-python2 python-notebook))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-notebook))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-mock" ,python2-mock)
+ ,@(package-native-inputs base)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'check 'disable-test-case
+ ;; The test requires network access to localhost. Curiously it
+ ;; fails with Python 2 only. Simply make the test-case return
+ ;; immediately.
+ (lambda _
+ (substitute*
+ "notebook/services/nbconvert/tests/test_nbconvert_api.py"
+ (("formats = self.nbconvert_api") "return #")))))))))))
(define-public python-widgetsnbextension
(package