summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-09-26 16:26:08 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-09-28 20:24:25 +0200
commit025b196d9b739418dd9d305864fdb1fb1d0d5af2 (patch)
tree2706548a90c434080159aea8920ee95d28312081 /gnu/packages/python.scm
parent18a26f1c1300773ec01bc0afb86ca863b22fa285 (diff)
gnu: python-numpy: Update to 1.13.1.
* gnu/packages/python.scm (python-numpy, python2-numpy): Update to 1.13.1. [source]: Download the zip release from pypi instead of a git snapshot. [native-inputs]: Add unzip. [arguments]: Set SHELL environment variable. Co-authored by Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e266c5ef0..e44462b013 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3720,22 +3720,21 @@ between language specification and implementation aspects.")
(define-public python-numpy
(package
(name "python-numpy")
- (version "1.12.0")
+ (version "1.13.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://github.com/numpy/numpy/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "numpy" version ".zip"))
(sha256
(base32
- "025d4j4aakcp8w5i5diqh812cbbjgac7jszx1j56ivrbi1i8vv7d"))))
+ "1fsgkhh1vdkhmlz8vmdgxnj9n9yaanckxxzz9s0b4p08fqvjic69"))))
(build-system python-build-system)
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
- `(("python-cython" ,python-cython)
+ `(("unzip" ,unzip)
+ ("python-cython" ,python-cython)
("python-nose" ,python-nose)
("gfortran" ,gfortran)))
(arguments
@@ -3743,6 +3742,8 @@ between language specification and implementation aspects.")
(modify-phases %standard-phases
(add-before 'build 'set-environment-variables
(lambda* (#:key inputs #:allow-other-keys)
+ ;; numpy's distutils uses $SHELL to run external commands.
+ (setenv "SHELL" "bash")
(call-with-output-file "site.cfg"
(lambda (port)
(format port