summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-05-29 19:00:34 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-01 22:38:45 +0200
commit1a024de45e0fe57342d3cec3ba54e129976fd914 (patch)
tree939b0941374f45e4232ed672ac9c3a694cb85b9b /gnu/packages/python.scm
parentb8fdbca32026a7f814f2bb2064774c54d803a8a6 (diff)
gnu: Add python-sqlparse and python2-sqlparse.
* gnu/packages/python.scm (python-sqlparse, python2-sqlparse): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 043c2a54f4..642fbd6ffe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8853,3 +8853,37 @@ multiple processes (imagine multiprocessing, billiard, futures, celery etc).
(define-public python2-tblib
(package-with-python2 python-tblib))
+
+(define-public python-sqlparse
+ (package
+ (name "python-sqlparse")
+ (version "0.1.19")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sqlparse" version))
+ (sha256
+ (base32
+ "1s2fvaxgh9kqzrd6iwy5h7i61ckn05plx9np13zby93z3hdbx5nq"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ ;; setup.py-integrated 2to3 only affects the build files, but
+ ;; py.test is using the source files. So we need to convert them
+ ;; manually.
+ (when (zero? (system* "python3"))
+ (system* "2to3" "--no-diff" "-wn" "sqlparse" "tests"))
+ (zero? (system* "py.test")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/andialbrecht/sqlparse")
+ (synopsis "Non-validating SQL parser")
+ (description "Sqlparse is a non-validating SQL parser for Python. It
+provides support for parsing, splitting and formatting SQL statements.")
+ (license bsd-3)))
+
+(define-public python2-sqlparse
+ (package-with-python2 python-sqlparse))