summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-12 21:27:06 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-10 02:36:35 +0200
commit4792a0321a5163ed043d404925c8ab03efae1223 (patch)
tree922ea8514eb000321143e7d3cee14e71232d9b5a /gnu/packages/python.scm
parent1898eaa3357124034fecfbeb157b39b0f4e8c0c0 (diff)
gnu: python2-unittest2: Update to 1.1.0.
* gnu/packages/python.scm (python2-unittest2): Update to 1.1.0. * gnu/packages/patches/python2-unittest2-remove-argparse.patch: New file. * gnu/local.mk: Add it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fd08f1a469..f5e92d8890 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1843,7 +1843,7 @@ standard library.")
(define-public python2-unittest2
(package (inherit python-unittest2)
(name "python2-unittest2")
- (version "0.5.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -1852,7 +1852,12 @@ standard library.")
version ".tar.gz"))
(sha256
(base32
- "0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
+ "0y855kmx7a8rnf81d3lh5lyxai1908xjp0laf4glwa4c8472m212"))
+ (patches
+ (search-patches "python2-unittest2-remove-argparse.patch"))))
+ (propagated-inputs
+ `(("python2-six" ,python2-six)
+ ("python2-traceback2" ,python2-traceback2)))
(arguments
`(#:python ,python-2
#:tests? #f)))) ; no setup.py test command