summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-23 21:09:32 -0400
committerLeo Famulari <leo@famulari.name>2017-10-08 13:36:20 -0400
commitd7eb680d85af810886af908916204a9ee7e68f10 (patch)
tree70fddb134e35a723105e302479414f50d8dcad6e /gnu/packages/python.scm
parent3ceb70e1e68f8e57fd3e9368cd3e0650ab5e4987 (diff)
gnu: Add python-guzzle-sphinx-theme.
* gnu/packages/python.scm (python-guzzle-sphinx-theme, python2-guzzle-sphinx-theme): New variables. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cc7aa8fa4e..8521ab352a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3390,6 +3390,30 @@ sources.")
(define-public python2-sphinx-rtd-theme
(package-with-python2 python-sphinx-rtd-theme))
+(define-public python-guzzle-sphinx-theme
+ (package
+ (name "python-guzzle-sphinx-theme")
+ (version "0.7.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "guzzle_sphinx_theme" version))
+ (sha256
+ (base32
+ "1rnkzrrsbnifn3vsb4pfaia3nlvgvw6ndpxp7lzjrh23qcwid34v"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/guzzle/guzzle_sphinx_theme")
+ (synopsis "Sphinx theme used by Guzzle")
+ (description "This package provides guzzle_sphinx_theme, a theme for the
+Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
+and several other projects.")
+ (license license:expat)))
+
+(define-public python2-guzzle-sphinx-theme
+ (package-with-python2 python-guzzle-sphinx-theme))
+
(define-public python-rst.linker
(package
(name "python-rst.linker")