summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-05-01 20:22:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-05-01 23:59:15 +0200
commite537c917e89a2335af3a120c549e555cf02daccb (patch)
tree95beeaf62c273a54f499e38e62ac845757652908 /gnu/packages/python.scm
parentdd5bb841bf612e8f93689d11fc6ca670877ed060 (diff)
gnu: Add python-sockjs-tornado.
* gnu/packages/python.scm (python-sockjs-tornado): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b715289773..35b2592783 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4217,6 +4217,38 @@ routines such as routines for numerical integration and optimization.")
(package-with-python2
(strip-python2-variant python-scipy)))
+(define-public python-sockjs-tornado
+ (package
+ (name "python-sockjs-tornado")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sockjs-tornado" version))
+ (sha256
+ (base32
+ "16cff40nniqsyvda1pb2j3b4zwmrw7y2g1vqq78lp20xpmhnwwkd"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; There are no tests, and running the test phase requires missing
+ ;; dependencies
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-tornado" ,python-tornado)))
+ (home-page "http://github.com/mrjoes/sockjs-tornado/")
+ (synopsis
+ "SockJS python server implementation on top of Tornado framework")
+ (description
+ "SockJS-tornado provides the server side counterpart to a SockJS client
+library, through the Tornado framework.
+
+SockJS provides a low latency, full duplex, cross-domain communication channel
+between a web browser and web server.")
+ (license license:expat)))
+
+(define-public python2-sockjs-tornado
+ (package-with-python2 python-sockjs-tornado))
+
(define-public python-socksipy-branch
(package
(name "python-socksipy-branch")