summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-25 21:38:04 +0200
committerAlex Kost <alezost@gmail.com>2015-07-31 10:59:32 +0300
commit429fdea1abbdf4884acb4441da458f65fc08e9df (patch)
tree959166da31858172cadee4f5fbd0847737dadf6f /gnu/packages/python.scm
parentde73dbf62d2696746f6de9dce79b1fe537c51613 (diff)
gnu: Add python-paramiko.
* gnu/packages/python.scm (python-paramiko, python2-paramiko): New variables. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ab89fd0d60..3ee46f3759 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,38 @@ pidof, tty, taskset, pmap.")
(define-public python2-psutil
(package-with-python2 python-psutil))
+(define-public python-paramiko
+ (package
+ (name "python-paramiko")
+ (version "1.15.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/paramiko/paramiko-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0mbfzm9zlrz6mla9xakrm8wkll3x035f9rj3c5pbgjzfldqscmjg"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("python-ecdsa" ,python-ecdsa)
+ ("python-pycrypto" ,python-pycrypto)))
+ (home-page "http://www.paramiko.org/")
+ (synopsis "SSHv2 protocol library")
+ (description "Paramiko is a python implementation of the SSHv2 protocol,
+providing both client and server functionality. While it leverages a Python C
+extension for low level cryptography (PyCrypto), Paramiko itself is a pure
+Python interface around SSH networking concepts.")
+ (license lgpl2.1+)))
+
+(define-public python2-paramiko
+ (package-with-python2 python-paramiko))
+
+
(define-public python-httplib2
(package
(name "python-httplib2")