summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:49:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commit7184b4b1bd839cd4fd0c9630c050c7854174057d (patch)
tree4d0a639e98498bda398557ab53a674caaf332902 /gnu/packages/python.scm
parentda6dd842d038aa0761918305953ad92951fb663f (diff)
gnu: Remove now unneeded 'localedef' invocations.
This is a followup to commit b0fd2bd. * gnu/packages/gawk.scm (gawk)[arguments] <install-locales>: Add comment on why we leave this here. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'install-locales' phase. * gnu/packages/swig.scm (swig)[arguments]: Likewise. * gnu/packages/python.scm (python-matplotlib): Remove 'LOCPATH' setting and 'localedef' invocation. (python-scipy): Likewise.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0df91d69cb..7569770889 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2251,12 +2251,6 @@ backend = GTK3Agg~%")))))
(info (string-append data "/info"))
(html (string-append doc "/html")))
(with-directory-excursion "doc"
- ;; Install and set UTF-8 locale to avoid an encoding error.
- (setenv "LOCPATH" (getcwd))
- (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.UTF-8")
- (setenv "LANG" "en_US.UTF-8")
;; Produce pdf in 'A4' format.
(substitute* (find-files "." "conf\\.py")
(("latex_paper_size = 'letter'")
@@ -2349,12 +2343,6 @@ toolkits.")
(html (string-append doc "/html"))
(pyver ,(string-append "PYVER=")))
(with-directory-excursion "doc"
- ;; Install and set UTF-8 locale to avoid an encoding error.
- (setenv "LOCPATH" (getcwd))
- (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.UTF-8")
- (setenv "LANG" "en_US.UTF-8")
;; Fix generation of images for mathematical expressions.
(substitute* (find-files "source" "conf\\.py")
(("pngmath_use_preview = True")