summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-09-06 10:01:23 +0300
committerLudovic Courtès <ludo@gnu.org>2017-09-08 18:12:51 +0200
commit1eb6b724834e2405c16a3ef3299bd68d6f622dec (patch)
tree187113291a810529d47af63c495fa311a256b49d /gnu/packages/python.scm
parent4967946b8ae81794971f72fe2e40a2bc428f91b6 (diff)
gnu: Add python-betamax-matchers.
* gnu/packages/python.scm (python-betamax-matchers, python2-betamax-matchers): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bf669a5317..d3df1ac5c5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13201,6 +13201,30 @@ replay them during future tests. It is designed to work with python-requests.")
(define-public python2-betamax
(package-with-python2 python-betamax))
+(define-public python-betamax-matchers
+ (package
+ (name "python-betamax-matchers")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "betamax-matchers" version))
+ (sha256
+ (base32
+ "07qpwjyq2i2aqhz5iwghnj4pqr2ys5n45v1vmpcfx9r5mhwrsq43"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-betamax" ,python-betamax)
+ ("python-requests-toolbelt" ,python-requests-toolbelt)))
+ (home-page "https://github.com/sigmavirus24/betamax_matchers")
+ (synopsis "VCR imitation for python-requests")
+ (description "@code{betamax-matchers} provides a set of Matchers for
+Betamax.")
+ (license license:asl2.0)))
+
+(define-public python2-betamax-matchers
+ (package-with-python2 python-betamax-matchers))
+
(define-public python-s3transfer
(package
(name "python-s3transfer")