summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-05 12:09:59 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-09-17 11:05:33 +1000
commit77e5c370322399bc4e6570c6a25e7e2676379085 (patch)
tree782c2990113b3e9b608948dc21b352ee229aebc8 /gnu/packages/python.scm
parent00c788824172d0f942cbee274c96941c505596f7 (diff)
gnu: python-orator: Update to 0.9.7.
* gnu/packages/python.scm (python-orator, python2-orator): Update to 0.9.7. [arguments]: Enable tests. Loosen dependency requirements. [propagated-inputs]: Remove python-arrow. Add python-backpack, python-pendulum, python-pygments, python-six. (python2-orator)[propagated-inputs]: Also remove python2-ipaddress.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 26 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c431993fa8..24fca7e4dd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -109,6 +109,7 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
@@ -12232,24 +12233,44 @@ mocks, stubs and fakes.")
(define-public python-orator
(package
(name "python-orator")
- (version "0.8.2")
+ (version "0.9.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "orator" version))
(sha256
(base32
- "1li49irsqha17nrda4nsb48biyy0rarp9pphf0jpqwm5zr8hv569"))))
+ "14r58z64fdp76ixnvmi4lni762b405ynmsx6chr1qihs3yl9zn6c"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; no tests
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'loosen-dependencies
+ ;; Tests are not actually run since they are not included with the
+ ;; distributed package, but dependencies are checked.
+ (lambda _
+ (substitute* "setup.py"
+ ((",<.*'") "'")
+ (("flexmock==0.9.7") "flexmock")
+ ;; The pytest-mock package is out of date, so we remove minimum
+ ;; version requirement.
+ (("pytest-mock.*'") "pytest-mock'"))
+ #t)))))
+ (native-inputs
+ `(("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest" ,python-pytest-3.0)
+ ("python-flexmock" ,python-flexmock)))
(propagated-inputs
- `(("python-arrow" ,python-arrow)
+ `(("python-backpack" ,python-backpack)
("python-blinker" ,python-blinker)
("python-cleo" ,python-cleo)
("python-faker" ,python-faker)
("python-inflection" ,python-inflection)
("python-lazy-object-proxy" ,python-lazy-object-proxy)
+ ("python-pendulum" ,python-pendulum)
("python-pyaml" ,python-pyaml)
+ ("python-pygments" ,python-pygments)
("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)
("python-wrapt" ,python-wrapt)))
(home-page "https://orator-orm.com/")
(synopsis "ActiveRecord ORM for Python")
@@ -12260,12 +12281,7 @@ implementation for Python.")
(properties `((python2-variant . ,(delay python2-orator))))))
(define-public python2-orator
- (let ((base (package-with-python2 (strip-python2-variant python-orator))))
- (package
- (inherit base)
- (propagated-inputs
- `(("python2-ipaddress" ,python2-ipaddress)
- ,@(package-propagated-inputs base))))))
+ (package-with-python2 (strip-python2-variant python-orator)))
(define-public python-prompt-toolkit
(package