summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2017-08-20 15:40:56 +1000
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-08-30 09:20:52 +0200
commit7a276cd94501c7159a63625e7e9188a05b0709da (patch)
tree101d49ca9a257fdbd29501f5a687cddd088d77f6 /gnu/packages/python.scm
parent07e62ae1c20977a622a6b623a8416ed1213d3113 (diff)
gnu: Add python-pyaes.
* gnu/packages/python.scm (python-pyaes, python2-pyaes): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dfc1b00906..e8018b422d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15987,3 +15987,25 @@ version of @code{SocksiPy} with bug fixes and extra features.")
(define-public python2-pysocks
(package-with-python2 python-pysocks))
+
+(define-public python-pyaes
+ (package
+ (name "python-pyaes")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyaes" version))
+ (sha256
+ (base32
+ "0bp9bjqy1n6ij1zb86wz9lqa1dhla8qr1d7w2kxyn7jbj56sbmcw"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/ricmoo/pyaes")
+ (synopsis "Implementation of AES in Python")
+ (description "This package contains a pure-Python implementation of the
+AES block cipher algorithm and the common modes of operation (CBC, CFB, CTR,
+ECB and OFB).")
+ (license license:expat)))
+
+(define-public python2-pyaes
+ (package-with-python2 python-pyaes))