summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2017-08-23 22:19:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-24 21:27:23 +0200
commit84342e2fa95fb5ff972c5c216b0548787e25f142 (patch)
tree48de88c76b6cf679e099fab91fa8cfb9fe949eb3 /gnu/packages/python.scm
parenta251838d6788476248bf84a994dcaf95cda8febf (diff)
gnu: Add honcho.
* gnu/packages/python.scm (python-honcho, python2-honcho): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 454ce1c258..4bd777c09e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5226,6 +5226,53 @@ cluster without needing to write any wrapper code yourself.")
(define-public python2-gridmap
(package-with-python2 python-gridmap))
+(define-public python-honcho
+ (package
+ (name "python-honcho")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nickstenning/honcho/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0zizn61n5z5hq421hkypk9pw8s6fpxw30f4hsg7k4ivwzy3gjw9j"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest-3.0)
+ ("python-mock" ,python-mock)
+ ("python-tox" ,python-tox)
+ ("which" ,which))) ;for tests
+ (propagated-inputs
+ `(("python-jinja2" ,python-jinja2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; fix honcho path in testsuite
+ (substitute* "tests/conftest.py"
+ (("'honcho'") (string-append "'" (assoc-ref outputs "out")
+ "/bin/honcho" "'")))
+ ;; It's easier to run tests after install.
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "py.test" "-v")))))))
+ (home-page "https://github.com/nickstenning/honcho")
+ (synopsis "Manage Procfile-based applications")
+ (description
+ "A Procfile is a file which describes how to run an application
+consisting of serveral processes. honcho starts all listed processes.
+The output of all running processes is collected by honcho and
+displayed.")
+ (license license:expat)))
+
+(define-public python2-honcho
+ (package-with-python2 python-honcho))
+
(define-public python-pexpect
(package
(name "python-pexpect")