summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-08-29 16:02:50 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-09-01 11:14:16 +0530
commita0596a2f27c339bcb4c5d3f2ffc8d6df38ff7947 (patch)
tree4c7464a39a093903a88d5a6520011ca068028e4b /gnu/packages/python.scm
parentf618086220106a15842fce9b4cbe1525a1473f42 (diff)
gnu: python2-larch: Enable tests.
* gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python2-larch)[source]: Use it. [arguments]: Move 'check' phase to before 'build' phase.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8bdd865af3..874ad82d91 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages backup)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
@@ -14193,12 +14194,26 @@ happens using the @code{logging} library.")
(uri (string-append
"http://git.liw.fi/cgi-bin/cgit/cgit.cgi/larch/snapshot/larch-"
version ".tar.gz"))
+ (patches (search-patches
+ "python2-larch-coverage-4.0a6-compatibility.patch"))
(sha256
(base32
"1p4knkkavlqymgciz2wbcnfrdgdbafhg14maplnk4vbw0q8xs663"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; check phase needs to be run before the build phase. If not,
+ ;; coverage-test-runner looks for tests for the built source files,
+ ;; and fails.
+ (delete 'check)
+ (add-before 'build 'check
+ (lambda _
+ (zero? (system* "make" "check")))))))
+ (native-inputs
+ `(("cmdtest" ,cmdtest)
+ ("python2-coverage-test-runner" ,python2-coverage-test-runner)))
(propagated-inputs
`(("python2-tracing" ,python2-tracing)))
(home-page "https://liw.fi/larch/")