summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-08-30 17:08:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-30 17:31:59 +0200
commitbeed6abc1dcdd4d373946d18b548e7f148ba0a0f (patch)
tree49ec71cdc23d7854594e74db82d05e57c16e93c5 /gnu/packages/python.scm
parentbac5fd21a138d34df6803645df8f4c34c27d7d21 (diff)
gnu: Add python-colormath.
* gnu/packages/python.scm (python-colormath, python2-colormath): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2d4a5609cb..921937e1a1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3774,6 +3774,30 @@ objects.")
(define-public python2-munch
(package-with-python2 python-munch))
+(define-public python-colormath
+ (package
+ (name "python-colormath")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colormath" version))
+ (sha256
+ (base32
+ "01wp5xwm0a89wdm1dc9rr1ij90idzdiiipxdj1yslhqzkhnjnfh0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-networkx" ,python-networkx)
+ ("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/gtaylor/python-colormath")
+ (synopsis "Color math and conversion library")
+ (description
+ "This is a Python library for color math and conversions.")
+ (license license:bsd-3)))
+
+(define-public python2-colormath
+ (package-with-python2 python-colormath))
+
(define-public python2-fastlmm
(package
(name "python2-fastlmm")