summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-05 12:10:00 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-09-17 11:07:46 +1000
commitda1f7a9e16d7debd59b8e1d39291cdf4cc4f6ea0 (patch)
tree952dc10322f65f069ae188637b86778cd8d63a40 /gnu/packages/python.scm
parent77e5c370322399bc4e6570c6a25e7e2676379085 (diff)
gnu: python-orator: Move to (gnu packages databases).
* gnu/packages/python.scm: Remove (gnu packages time) import. (python-orator, python2-orator): Move from here ... * gnu/packages/databases.scm: ... to here.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm54
1 files changed, 0 insertions, 54 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 24fca7e4dd..475b6903f3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -109,7 +109,6 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
- #:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
@@ -12230,59 +12229,6 @@ mocks, stubs and fakes.")
(define-public python2-flexmock
(package-with-python2 python-flexmock))
-(define-public python-orator
- (package
- (name "python-orator")
- (version "0.9.7")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "orator" version))
- (sha256
- (base32
- "14r58z64fdp76ixnvmi4lni762b405ynmsx6chr1qihs3yl9zn6c"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'loosen-dependencies
- ;; Tests are not actually run since they are not included with the
- ;; distributed package, but dependencies are checked.
- (lambda _
- (substitute* "setup.py"
- ((",<.*'") "'")
- (("flexmock==0.9.7") "flexmock")
- ;; The pytest-mock package is out of date, so we remove minimum
- ;; version requirement.
- (("pytest-mock.*'") "pytest-mock'"))
- #t)))))
- (native-inputs
- `(("python-pytest-mock" ,python-pytest-mock)
- ("python-pytest" ,python-pytest-3.0)
- ("python-flexmock" ,python-flexmock)))
- (propagated-inputs
- `(("python-backpack" ,python-backpack)
- ("python-blinker" ,python-blinker)
- ("python-cleo" ,python-cleo)
- ("python-faker" ,python-faker)
- ("python-inflection" ,python-inflection)
- ("python-lazy-object-proxy" ,python-lazy-object-proxy)
- ("python-pendulum" ,python-pendulum)
- ("python-pyaml" ,python-pyaml)
- ("python-pygments" ,python-pygments)
- ("python-simplejson" ,python-simplejson)
- ("python-six" ,python-six)
- ("python-wrapt" ,python-wrapt)))
- (home-page "https://orator-orm.com/")
- (synopsis "ActiveRecord ORM for Python")
- (description
- "Orator provides a simple ActiveRecord-like Object Relational Mapping
-implementation for Python.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-orator))))))
-
-(define-public python2-orator
- (package-with-python2 (strip-python2-variant python-orator)))
-
(define-public python-prompt-toolkit
(package
(name "python-prompt-toolkit")