summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:13 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:52 -0500
commit0151a8df22e578e06b7a4ed633a018c58330f625 (patch)
tree834b5254c8ed8ece93151c4de240b39228002f53 /gnu/packages/python.scm
parent460fccd4b3e6f2f595202747981046c7af103c59 (diff)
gnu: Add python-pygit2.
* gnu/packages/python.scm (python-pygit2, python2-pygit2): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a4ae51b92f..c69a49f0b2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3465,6 +3465,33 @@ association studies (GWAS) on extremely large data sets.")
(define-public python2-numpy
(package-with-python2 python-numpy))
+(define-public python-pygit2
+ (package
+ (name "python-pygit2")
+ (version "0.24.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pygit2" version))
+ (sha256
+ (base32
+ "0shnafv9zc483wmcr4fzgvirg1qzz42xpdqd4a3ad39sdj1qbbia"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-cffi" ,python-cffi)
+ ("libgit2" ,libgit2)
+ ("python-tox" ,python-tox)))
+ (home-page "https://github.com/libgit2/pygit2")
+ (synopsis "Python bindings for libgit2")
+ (description "Pygit2 is a set of Python bindings to the libgit2 shared
+library, libgit2 implements Git plumbing.")
+ ;; GPL2.0 only, with linking exception.
+ (license license:gpl2)))
+
+(define-public python2-pygit2
+ (package-with-python2 python-pygit2))
+
(define-public python-pyparsing
(package
(name "python-pyparsing")